DMVPN

conf-dmvpn

NBMA: nonbroadcast multiaccess

Turning off split horizon is needed on Tunnel interface if any routing protocol is used:

When the device is connected to a spoke and not only the HUB (and some routing protocol is running) then split horizon causing problems.
When the device receives an update for example from the HUB it cannot forward the routing update towards another spoke because it should have send it on the same interface (on the tunnel interface).

Configuration of the HUB:

interface FastEthernet0/0
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
 !
end

interface Tunnel1
 ip address 192.168.88.1 255.255.255.248
 no ip redirects
 ip nhrp map multicast dynamic #automatically add routers to the multicast NHRP mappings (needed for dynamic routing protocols)
 ip nhrp network-id 1 #enables NHRP on the interface; routers have to be in the same group to communicate
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint  #Enables a GRE tunnel to be used in multipoint NBMA mode.

Configuration of the Spokes:

interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.0
 duplex auto
 speed auto
 !
end

interface Tunnel1
 ip address 192.168.88.2 255.255.255.248
 no ip redirects
 ip nhrp map multicast 10.0.1.1 #destination of broadcast or multicast messages
 ip nhrp map 192.168.88.1 10.0.1.1 #mapping statically configured to the next hop server ( first tunnel IP, then interface IP)
 ip nhrp network-id 1 #enables NHRP on the interface; routers have to be in the same group to communicate
 ip nhrp nhs 192.168.88.1 
 tunnel source FastEthernet0/0 
 tunnel mode gre multipoint #Enables a GRE tunnel to be used in multipoint NBMA mode

Verification

R2#sho dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
 N - NATed, L - Local, X - No Socket
 # Ent --> Number of NHRP entries with same NBMA peer
 NHS Status: E --> Expecting Replies, R --> Responding
 UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
 1 10.0.1.1 192.168.88.1 UP 03:00:13 S
 1 10.0.1.3 192.168.88.3 UP 00:00:05 D
R2#sho ip nhrp
192.168.88.1/32 via 192.168.88.1
 Tunnel1 created 03:00:53, never expire
 Type: static, Flags: used
 NBMA address: 10.0.1.1
192.168.88.2/32 via 192.168.88.2
 Tunnel1 created 00:00:08, expire 01:59:53
 Type: dynamic, Flags: router unique local
 NBMA address: 10.0.1.2
 (no-socket)
192.168.88.3/32 via 192.168.88.3
 Tunnel1 created 00:00:08, expire 01:59:51
 Type: dynamic, Flags: router used
 NBMA address: 10.0.1.3
R2#sho int tun1
Tunnel1 is up, line protocol is up
 Hardware is Tunnel
 Internet address is 192.168.88.2/29
 MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation TUNNEL, loopback not set
 Keepalive not set
 Tunnel source 10.0.1.2 (FastEthernet0/0)
 Tunnel Subblocks:
 src-track:
 Tunnel1 source tracking subblock associated with FastEthernet0/0
 Set of tunnels with source FastEthernet0/0, 1 member (includes iterators), on interface <OK>
 Tunnel protocol/transport multi-GRE/IP
 Key disabled, sequencing disabled
 Checksumming of packets disabled
 Tunnel TTL 255, Fast tunneling enabled
 Tunnel transport MTU 1476 bytes
 Tunnel transmit bandwidth 8000 (kbps)
 Tunnel receive bandwidth 8000 (kbps)
 Last input 00:04:58, output 00:04:58, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/0 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 12 packets input, 1572 bytes, 0 no buffer
 Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
 18 packets output, 2164 bytes, 0 underruns
 0 output errors, 0 collisions, 0 interface resets
 0 unknown protocol drops
 0 output buffer failures, 0 output buffers swapped out
Advertisements