IPv6 Internet Connections

  • How can the ISP give IPv6 address to the customer?
    • manual configuration
    • stateless address autoconfiguration
    • stateless DHCPv6
    • stateful DHCPv6
    • DHCPv6 Prefix Delegation (DHCPv6-PD)
  • How does Statless Address  Autoconfiguration (SLAAC) work?
    • The ISP sends the CPE and Router Advertisement (RA), which advertises the IPv6 prefix. The customer router uses the prefix and fills the remaining part by either random or with EUI-64.
  • How does stateless and stateful DHCPv6 work?
    • It is used when not only an IPv6 address but i.e. DNS server IP is needed for the customer. DHCPv6  uses SLAAC but the RA has the other-config-flag set, which tells the router to check with a DHCP server to obtain additional IPv6 information.
    • Since stateless DHCPv6 uses SLAAC it does not know the actual IPv6 addresses of the routers. Stateful DHCPv6 sets the managed-config-flag to instruct the router to obtain its IPv6 address from the DHCPv6 server.
  • How does DHCPv6 PD work?
    • It can assign multiple IPv6 networks to a router. The router could then assign those different IPv6 network to its various interfaces.
  • How do you configure IPv6 address and IPv6 default route?
    • ipv6 address IP/prefix-length
    • ipv6 route ::/0 next-hop-ipv6-address
  • What is the difference between IPv6 and IPv4 ACL?
    • IPv6 ACLs are named and extended by default
    • IPv4 ACL has implicit deny at the end
      IPv6 ACL has 3 implicit entries:
         permit icmp any any nd-na
         permit icmp any any nd-ns
         deny ipv6 any any
      (Neighbor Discovery (like ARP) and Neighbor Solicitations)

BGP Support for IPv6

  • Which version of BGP supports IPv6?
    • Multiprotocol BGP (MP-BGP)
  • What are the two ways of using IPv6 on BGP?
    • configuring IPv4 BGP session and use that single session to carry IPv4 and IPv6 route information
    • configuring IPv4 BGP session which carries only IPv4 network advertisements and configuring IPv6 BGP session which carries only IPv6 network advertisements
  • What are the pros and cons of these approaches?
    • Single IPv4 BGP session:
      • fewer neighborships formed
      • need to create a route-map to modify the Next-Hop BGP attribute
    • Dual (IPv4/IPv6) BGP sessions:
      • more neighborships
      • no need for route-map with Next-Hop BGP attributes
  • Refer to the exhibit! How do you configure IPv6 over IPv4 BGP session?
    ipv6-over-ipv4-bgp.PNG

    • !R1
      ipv6 unicast-routing
      !
      router bgp 64701
         neighbor 192.51.100.2 remote-as 64702
         !
         address-family ipv4
            network 192.0.2.0
            neighbor 192.51.100.2 activate  //automatic
         exit-address-family
      !
         address-family ipv6
            network 2000:1::/64
            neighbor 198.51.100.2 activate    //need to configure manually
            neighbor 198.51.100.2 route-map IPV6-NEXT-HOP out
         exit-address-family
      !
      route-map IPV6-NEXT-HOP permit 10
         set ipv6 next-hop 2000:2::1

      Configuration is similar on the opposite side.

  • Refer to the exhibit! How do you configure IPv6 over IPv6 BGP session?ipv6-over-ipv4-bgp.PNG
    • ipv6 unicast-routing
      !
      router bgp 64701
       neighbor 2000:2::2 remote-as 64702
      !
       address-family ipv4
         no neighbor 2000:2::2 activate      //automatically
       exit-address-family
      !
       address-family ipv6
         network 2000:1::/64
         neighbor 2000:2::2 activate
       exit-address-family

 

 

Advertisements