EIGRP for IPv6

  • What is the multicast update destination of EIGRP with IPv6 ?
    • FF02::A
  • How do you configure EIGRP using IPv6?
    • enable ipv6
      ipv6 unicast-routing
    • enable eigrp
      ipv6 router eigrp AS-number
    • configure IPv6 unicast address on each (used) interfaces
      interface subcommand: ipv6 address address/prefix
    • enable eigrp on interface
      ipv6 eigrp AS-number
    • enable EIGRP process
      eigrp subcommand: no shut
    • ipv6 unicast-routing
      !
      interface Fa0/0
        ipv6 address 2012::1/64
        ipv6 eigrp 9
      !
      interface Fa1/1
        ipv6 address 2013::1/64
        ipv6 eigrp 9
      !
      ipv6 router eigrp 9 
        eigrp router-id 1.1.1.1
  • How does EIGRP chooses router id?
    • 1. uses configured value
    • 2. uses the highest IPv4 address on an up/up loopback interface
    • 3. uses the highest IPv4 address on an up/up non-loopback interface
    • If there is no  RID configured / IPv4 address then the RID=0.0.0.0
  • How does the EIGRP commands differ in IPv6?
    • They are almost the same. Instead of “ip” the IOS uses “ipv6” ie.: sho ipv6 route

Named EIGRP

  • What is named EIGRP good for?
    • You can configure/administrate different EIGRP network (IPv6/IPv4, vrfs..) on a single device
  • How do you configure a named EIGRP?
    • create named EIGRP virtual instance
      router eigrp virtual-instance-name
    • specify an address-family (ie.: network, stub, rotuer-id)
      address-family ipv4/ipv6 autonomous-system as-number
    • address-family-interface configuration mode (ie.: split-horizon, timers)
      af-interface default/interface-id 
    • address-family-topology configuration mode (ie.: maximum-paths, variance, summary)
      topology base
  • How do you verify a named EIGRP?
    • same way as a traditional EIGRP
!Named EIGRP example
router eigrp R1DEMO
!
address-family ipv4 unicast autonomous-system 1
 !
 af-interface default
 hello-interval 2
 hold-time 10
 passive-interface
 exit-af-interface
 !
 af-interface Serial1/0
 no passive-interface
 exit-af-interface
 !
 topology base
 variance 2
 exit-af-topology
 network 0.0.0.0
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 2
 !
 topology base
 variance 2
 exit-af-topology
 exit-address-family


!Router R2 Configuration
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ipv6 address 2003::1/64
!
interface Serial1/0
 ip address 10.1.1.2 255.255.255.252
 ipv6 address 2002::2/64
!
router eigrp R2DEMO
!
address-family ipv4 unicast autonomous-system 1
 !
 af-interface default
 hello-interval 2
 hold-time 10
 passive-interface
 exit-af-interface
 !
 af-interface Serial1/0
 no passive-interface
 exit-af-interface
 !
 topology base
 variance 2
 exit-af-topology
 network 0.0.0.0
 exit-address-family
 !
 address-family ipv6 unicast autonomous-system 2
 !
 topology base
 variance 2
 exit-af-topology
 exit-address-family
Advertisements