Network Types

  • What kind of network type does OSPF differentiate?
    • point-to-point
    • broadcast
    • nonbroadcast multiaccess (NBMA)
    • point-to-multipoint
    • virtual links
  • Describe point-to-point network!
    • Valid neighbors on PPP network will always become adjacent.
    • The OSPF packets use the 224.0.0.5 (all ospf routers) multicast address.
  • Describe broadcast (multiaccess) network!
    • They are capable of connecting more than 2 devices (within broadcast range)
    • DR/BDR are elected
    • OSPF packets are sent to 224.0.0.6 (all DR routers) and DR send packets to 224.0.0.5
  • Describe NBMA network!
    • Capable of connecting more than 2 routers but without broadcast / multicast.
    • An extra configuration might be necessary to establish neighborships
    • DR/BDR is elected
    • All OSPF packets are unicast
  • Describe point-to-multipoint network!
    • These are specially configured NBMA networks
    • The networks are treated as a collection of point-to-point links
    • DR/BDR is not elected
    • All OSPF packets are unicast
  • How can you check what network type has OSPF selected?
    • show ip ospf interface
    • network-type.PNG
  • How do you configure Non-broadcast!
    • !Hub
      interface Se0/0
        ip address 192.168.123.1 255.255.255.0
        encapsulation frame-relay
        ip ospf network non-broadcast
      router ospf 1
        network 0.0.0.0 255.255.255.255 area 0
        neighbor 192.168.123.2
        neighbor 192.168.123.3
      
      !Spoke
      interface Se0/0
        ip address 192.168.123.2 255.255.255.0
        encapsulation frame-relay
        ip ospf network non-broadcast
        ip ospf priority 0
      router ospf 1
        network 0.0.0.0 255.255.255.255 area 0
    • The Spokes cannot reach each other, so we need to turn off BDR selection! The HUB will do all the work (unicast).
  • How do you configure Broadcast?
    • !Hub
      interface Se0/0
        ip address 192.168.123.1 255.255.255.0
        encapsulation frame-relay
        ip ospf network broadcast
        frame-relay map ip 192.168.123.2 102 broadcast
        frame-relay map ip 192.168.123.3 103 broadcast
        no frame-relay inverse-arp
      router ospf 1
       network 0.0.0.0 255.255.255.255 area 0
      
      !Spoke
      interface Se0/0
       ip address 192.168.123.2 255.255.255.0
       encapsulation frame-relay
       ip ospf network broadcast
       frame-relay map ip 192.168.123.1 201 broadcast
       no frame-relay inverse-arp
      router ospf 1
       network 0.0.0.0 255.255.255.255 area 0
    • If you want the Spokes to communicate you must turn off inverse ARP and configure static frame-relay mapping with broadcast.
  • What is the common between P2P, Point-to-multipoint, Point-to-multipoint non-broadcast?
    • none of them are using DR/BDR
  • What is the default frame-relay network type? When you only configure “encaplusation frame-relay” under the serial interface?
    • point-to-multipoint
  • How do you configure OSPF with such network?
    • !Hub
      interface Se0/0
        ip address 192.168.123.1 255.255.255.0
        encapsulation frame-relay
        ip ospf network point-to-multipoint
      router ospf 1
       network 0.0.0.0 255.255.255.255 area 0
      
      !Spoke
      interface Se0/0
       ip address 192.168.123.2 255.255.255.0
       encapsulation frame-relay
        ip ospf network point-to-multipoint
      router ospf 1
       network 0.0.0.0 255.255.255.255 area 0
    • (No BR/BDR)
    • Spokes can communicate.
  • How do you configure point-to-multipoint non-broadcast?
    • Exatcly the same way. The only difference is that you have to configure frame-relay mapping manually.
  • How do you configure point-to-point?
    • !Hub
      interface Se0/0
        encapsulation frame-relay
        no frame-relay inverse-arp
      interface Se0/0.102
        ip addr 192.168.12.1 255.255.255.0
        frame-relay interface-dlci 102
        ip ospf network point-to-point
      interface Se0/0.103
        ip addr 192.168.13.1 255.255.255.0
        frame-relay interface-dlci 103
        ip ospf network point-to-point
      !
      router ospf 1
       network 0.0.0.0 255.255.255.255 area 0
      
      !Spoke
      interface Se0/0
        encapsulation frame-relay
        no frame-relay inverse-arp
      interface Se0/0.1
        ip address 192.168.12.1 255.255.255.0 
        frame-relay interface-dlci 201
        ip ospf network point-to-point
      
      router ospf 1
        network 0.0.0.0 255.255.255.255 area 0
  • What are the OSPF timer in P2P, Point-to-Multipoint, Broadcast and Non-broadcast network types?
    • Network Type Hello Interval (secs) Dead Interval (secs)
      Point-to-Point 10 40
      Point-to-Multipoint 30 120
      Broadcast 10 40
      Non-Broadcast 30 120

Route Filtering

  • What are the difficulties of OSPF route filtering?
    • We need to filter the LSA as they are used instead of simple advertisements. OSPF must know all Type 1-2 LSA-s to avoid routing loops! This way we cannot filter Type 1-2 LSA-s.
  • Regarding the above problem what can you filter?
    • Type 3 LSA on the ABR
    • Type 5 LSA on the ASBR
    • Routes that OSPF would normally add to the IP routing table on a single router
  • How do you filter Type 3 LSA on an ABR?
    • ospf subcommand: area number filter-list prefix name in|out
    • The routes permited in the prefix list will be allowed by the filter-list.
  • What is the difference between in / out (in the above command)?
    • When considering in/out think in the perspective of the area NOT the router!
  • When does distribute-list filter a route?
    • After SPF algorith finished and ready to put the route into the routing table:
      distribute-list-vs-ospf.PNG
  • How do you filter routes from LSDB to Routing Table?
    • ospf subcommand: distribute-list access-list/prefix/route-map name in
    • Only direction in  filters to Routing Table.

Route Summarization

  • What are the difficulties with OSPF route summarization?
    • Since the LSDB must match within an area there can be no summarization done.
    • Only ABR and ASBR can summarize routes.
  • How do you perform manual summarization at ABRs?
    • (router ospf) area area-id range ip-address mask  [cost cost]
  • What are the key parts of manual summarization at ABR?
    • the “area-id” part refers to the area where the subnet exist
    • the summary will be advertised to every other area
    • the ABR will not advertise the subordinate subnets Type 3 LSAs
    • by default the summary route will have the metric of the best metric among all subordinate subnets
    • if the subordinate subnets does not exist then the ABR will not advertise the summary route
  • How do you perform summarization at ASBR?
    • (router ospf) summary-address ip-address mask/prefix
  • What are the key parts of summarization at ASBR? What differs to ASBR summarization?
    • the summary will be advertised to every other area
    • the summary route will have the metric of the  best metric among all subordinate subnets (cannot be changed ! )
    • the ABR will not advertise the subordinate subnets Type 5 LSAs
    • if the subordinate subnets does not exist then the ABR will not advertise the summary route
    • to create the summary the ASBR advertises Type 5 LSAs

Default Routes

  • What are the 2 typical use of default routes in enterprises?
    • to direct the traffic toward the core of the network (which knows the more specific routes)
    • to direct the traffic toward the Internet gateways
  • How can you advertise a default route?
    • One way is to use area area-id range 0.0.0.0 0.0.0.0 at ABR so Type 3 LSA will be advertised.
    • Another way is to use  summary-address 0.0.0.0 at the ASBR, so Type 5 LSA will be advertised like a default route.
    • default-information originate is similar to the previous one. It creates Type 5 LSAs and advertises through the network.
  • How does default-information originate command work?
    • with default parameters, it injects a default route into OSPF as an External Type 2 route using Type 5 LSA with metric 1; this only works when a default route exist in the routing table
    • always: the default route is advertised even if there is no default route in the routing table
    • metric: you can change the default (1) metric
    • metric-type: Type 1 or Type 2 External
    • also route map can be added
    • route-map: ie.: You can specify a route map with a route. If the route exists in the routing table then the default route will be propagated.

Stub Areas

  • What is a stub area?
    • ABR do not advertise Type 5 LSAs (external routes) into the area
    • ABR creates a default route and advertises it to the stubby area (Type 3)
    • less CPU usage
  • What are the key features of stub areas?
    • ABR create a default route using Type 3 LSA and flood it into the stub area.
      This way the stub area can reach the external routes via default route.
    • ABR do not flood Type 5 LSA into the stub area
    • The default route metric is 1 unless otherwise configured using area area-num default-cost cost command.
    • Routers inside stub areas cannot redistribute external routes into the stubby areas (Type 5)
    • All routers in the area must be configured as stubby, else the neighborship wont be formed
      areas.PNG
  • Refer to the exhibit! What routes will R8 have?
    • stub-area.PNG
    • all the routes except the redistributed ones (53.0.0.0/24, also others like redistribute connected…)
    • !R8
      Gateway of last resort is 10.0.0.34 to network 0.0.0.0
      
      O*IA 0.0.0.0/0 [110/2] via 10.0.0.34, 00:01:45, FastEthernet0/0
       1.0.0.0/32 is subnetted, 1 subnets
      O IA 1.1.1.1 [110/3] via 10.0.0.34, 00:00:03, FastEthernet0/0
       3.0.0.0/32 is subnetted, 1 subnets
      O IA 3.3.3.3 [110/2] via 10.0.0.34, 00:01:06, FastEthernet0/0
       8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 8.8.8.0/24 is directly connected, Loopback1
      L 8.8.8.8/32 is directly connected, Loopback1
       10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
      O IA 10.0.0.4/30 [110/2] via 10.0.0.34, 00:01:45, FastEthernet0/0
      C 10.0.0.32/30 is directly connected, FastEthernet0/0
      L 10.0.0.33/32 is directly connected, FastEthernet0/0
  • What routers will R8 if R3 is configured as totally stubby?
    • External and inter-area routes will NOT be advertised on ABR. Only default route.
    • !R8
      Gateway of last resort is 10.0.0.34 to network 0.0.0.0
      
      O*IA 0.0.0.0/0 [110/2] via 10.0.0.34, 00:00:01, FastEthernet0/0
       8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 8.8.8.0/24 is directly connected, Loopback1
      L 8.8.8.8/32 is directly connected, Loopback1
       10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 10.0.0.32/30 is directly connected, FastEthernet0/0
      L 10.0.0.33/32 is directly connected, FastEthernet0/0
  • Refer to the exhibit! R8 and R3 are configured with “area 10 nssa” command. How will the network react to the 192.168.0.0/24 subnet?
    • nssa
    • R3 will have the subnet as Type-7 LSA:
      (Other routers in area 10 would have it as Type-7, but R8 knows it via EIGRP first)
    • R8
      Gateway of last resort is 10.0.0.34 to network 0.0.0.0
      
      O*IA 0.0.0.0/0 [110/2] via 10.0.0.34, 00:02:46, FastEthernet0/0
       8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 8.8.8.0/24 is directly connected, Loopback1
      L 8.8.8.8/32 is directly connected, Loopback1
       10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
      C 10.0.0.32/30 is directly connected, FastEthernet0/0
      L 10.0.0.33/32 is directly connected, FastEthernet0/0
      C 10.0.0.36/30 is directly connected, FastEthernet0/1
      L 10.0.0.37/32 is directly connected, FastEthernet0/1
      D 192.168.0.0/24 [90/156160] via 10.0.0.38, 00:12:36, FastEthernet0/1
    • R3
      Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route
      
      Gateway of last resort is not set
      
      ....
      O N2 192.168.0.0/24 [110/20] via 10.0.0.33, 00:02:03, FastEthernet0/1
    • R1 will see the route as a simple Type-5:
    • R1
      O E2 192.168.0.0/24 [110/20] via 10.0.0.6, 00:01:34, FastEthernet0/1
  • What kind of stubby areas do you know?
    • stub
    • totally stub
    • not-so-stubby
    • totally not-so-stubby
  • What does the totally means?
    • Stub: advertise: type 3; NO type 5
    • Not-So-Stubby: advertise type3; NO type 5 (rather type 7 😉 )
    • Totally-Stub: NO type 3 and type 5
    • Totally-Not-So-Stubby: NO type 3 and type 5; advertise type 7
  • How do you configure stubby and totally stubby areas?
    • area area-id stub  (on every router in the area)
    • area area-id stub no-summary (on ABRs; configuring stub on all other routers in the area still needed)
    • Setting metric: area area-id default-cost metric (on ABR)
  • What is the difference between stubby and not-so-stubby areas?
    • Stuby areas do not advertise Type 5 LSAs
    • NSSA do not advertisde Type 5 LSAs either, instead they advertise Type 7 LSAs. This way OSPF can redistribute external routes and inject Type 7 LSAs into the NSSA. It works somehow like tunneling. Type 7 LSA can travel through a NSSA and be injected into another area as a simple Type 5 LSA.
  • How do you configure NSSA and totally NSSA?
    • area area-number nssa
    • area area-number nssa no-summary
    • NSSA require that ABRs have the default-information-originate keyword specified: area area-number nssa default-information-originate
  • Describe all known LSAs !
    • ospf-lsa-types

OSPF Version 3

  • What is new in OSPFv3?
    • Type 3 LSA is renamed as Interarea prefix LSA for ABRs
    • Type 4 is renamed as Interarea prefix LSA for ASBRs
    • New LSA: Type 8 and Type 9
  • What is the purpose of Type 8 LSA ?
    • Link LSA: these only exist on a local link, where they are used by a router to advertise the routers link-local address to all other routers on the same link
  • What is the purpose of Type 9 LSA?
    • Intra-Area Prefix LSA: Send information about IPv6 networks attached to a router
  • How do you configure traditional OSPFv3 ?
    • ipv6 unicast-routing
    • ipv6 router ospf process-id
      • router-id rid
    • (interface) ipv6 ospf process-id area area-number
  • What router id does OSPFv3 use?
    • it uses a 32bit value, usually a IPv4 address
    • if there is no IPv4 address configured and RID is not configured manually either, the OSPF process will fail to start
  • How do you configure OSPFv3 Address Family?
    • router ospfv3 process-id
      • router-id rid
      • address-family ipv6/ipv4 unicast
    • (interface)ospfv3 process-id ipv4/ipv6 area area_number
Advertisements