Configure and verify PPP

  • Authentication (PAP, CHAP) – not in the book
    PPP includes authentication and vital error detection (unlike HDLC)

    •  Password Authentication Protocol (PAP):Username and password is sent in clear text, there is no protection from playback or trail-and-error attacks.
      !R1
      int se0/0
       ip address 10.0.0.1 255.255.255.0
       encapsulation ppp
       ppp authentication pap
       ppp pap sent-username R2-user password cisco
      username R1-user password cisco
      
      !R2
      int se0/0
       ip address 10.0.0.2 255.255.255.0
       encapsulation ppp
       ppp authentication pap
       ppp pap sent-username R1-user password cisco
      username R2-user password cisco
    • Challenge Authentication Protocol (CHAP):  User credentials are hashed.
      !R1
      interface Serial1/0
       ip address 10.11.12.1 255.255.255.0
       encapsulation ppp
       ppp authentication chap
       ppp chap hostname R2-user
       ppp chap password 0 cisco
      username R1-user password cisco
      
      !R2
      interface Serial1/0
       ip address 10.11.12.2 255.255.255.0
       encapsulation ppp
       ppp authentication chap
       ppp chap hostname R1-user
       ppp chap password 0 cisco
      username R2-user password cisco

      By default CHAP uses the remote hostname as username. If you would like to use a different username use: ppp chap hostname username

  • PPPoE (client side only) – not in the book
    • PPP Over Ethernet: This is a combination of PPP and Ethernet. PPP is encapsulated inside Ethernet, allowing transmission over any Ethernet friendly interface.
      !R1
      interface FastEthernet0/0
       no ip address
       pppoe enable group global
       pppoe-client dial-pool-number 1
      !
      !
      interface Dialer1
       ip address 10.0.0.2 255.255.255.0
       encapsulation ppp
       dialer pool 1
      
      !R2
      bba-group pppoe PPPOE
       virtual-template 1
      !
      interface FastEthernet0/0
       no ip address
       pppoe enable group PPPOE
      !
      interface Virtual-Template1
       ip address 10.0.0.1 255.255.255.0
  • Verification:
    • show ppp all

Explain Frame Relay

  • Operations
  • Point-to-point
  • Multipoint
Advertisements