Selective Acknowledgments (SACK)

TCP send another device 4 segments.

#1 arrived
#2 lost
#3 arrived
#4 arrived

When the receiver realizes that the third  segment arrived but there was no second segment it sends a duplicate acknowledgement for segment #1 but expends it with SACK telling that #3 #4 has already arrived.
As a result the sender retransmits ONLY #2 to the client. The receiver replies with ACK #4 so the sender know that everything arrived.

Support for SACK is negotiated at the beginning of a TCP connection; if both hosts support it, it may be used.

(global) ip tcp selective ack
(global) ip tcp timestap


UDP dominance / TCP starvation

It is a general best practice to not mix TCP-based traffic with UDP-based traffic (especially Streaming-Video) within a single service-provider class because of the behaviors of these protocols during periods of congestion. Specifically, TCP transmitters throttle back flows when drops are detected. Although some UDP applications have application-level windowing, flow control, and retransmission capabilities, most UDP transmitters are completely oblivious to drops and, thus, never lower transmission rates because of dropping.
When TCP flows are combined with UDP flows within a single service-provider class and the class experiences congestion, TCP flows continually lower their transmission rates, potentially giving up their bandwidth to UDP flows that are oblivious to drops. This effect is called TCP starvation/UDP dominance.
TCP starvation/UDP dominance likely occurs if TCP-based applications is assigned to the same service-provider class as UDP-based applications and the class experiences sustained congestion.
Granted, it is not always possible to separate TCP-based flows from UDP-based flows, but it is beneficial to be aware of this behavior when making such application-mixing decisions within a single service-provider class.


Diealer Persistent – PPPoE

The “dialer persistent” command (under interface configuration mode) allows a dial-on-demand routing (DDR) dialer profile connection to be brought up without being triggered by interesting traffic. When configured, the dialer persistent command starts a timer when the dialer interface starts up and starts the connection when the timer expires. If interesting traffic arrives before the timer expires, the connection is still brought up and set as persistent. An example of configuring is shown below:

interface Dialer1
ip address 12.12.12.1 255.255.255.0
encapsulation ppp
dialer-pool 1
dialer persistent

PPPoE phases

PPPoE provides a standard method of employing the authentication methods of the Point-to-Point Protocol (PPP) over an Ethernet network. When used by ISPs, PPPoE allows authenticated assignment of IP addresses. In this type of implementation, the PPPoE client and server are interconnected by Layer 2 bridging protocols running over a DSL or other broadband connection.

PPPoE is composed of two main phases:
+ Active Discovery Phase: In this phase, the PPPoE client locates a PPPoE server, called an access concentrator. During this phase, a Session ID is assigned and the PPPoE layer is established.
+ PPP Session Phase: In this phase, PPP options are negotiated and authentication is performed. Once the link setup is completed, PPPoE functions as a Layer 2 encapsulation method, allowing data to be transferred over the PPP link within PPPoE headers.


PPPoE Client configuration

int Dialer 1
   ip address negotiated   
   encapsulation ppp
   ppp chap hostname artemis
   ppp chap password cisco
   ip mtu 1492
   dialer pool 10

interface Fa0/0
   pppoe enabled
   pppoe-client dial-pool-number 10

Command: autonomous-system {autonomous-system-number}

An example of using “autonomous-system {autonomous-system-number}” command is shown below:

router eigrp 100
address-family ipv4 vrf Cust
net 192.168.12.0
autonomous-system 100
no auto-summary

This configuration is performed under the Provide Edge (PE) router to run EIGRP with a Customer Edge (CE) router. The “autonomous-system 100” command indicates that the EIGRP AS100 is running between PE & CE routers. It sets the EIGRP autonomous system number in a VRF.


HSRP Version 2

In case you have a running HSRP system and you want to change it to Version 2, the neighborship will fail, HSRP will restart.


Internet Protocol number 47 = GRE


TCP Window Scaling

You can turn on window scaling with the ip tcp-window size number command.
This need to be configured on both of the devices!

UDP does not have flow control. This could cause problems when congestion occurs. TCP will throttle back on transmission while UDP will do not. TCP starvation / UDP dominance.


OSPFv3 IPv6 is using IPv6 IPSec for authentication


R1(config)#ip route 0.0.0.0 0.0.0.0 172.20.20.2 track 10
R1(config)#no ip route 0.0.0.0 0.0.0.0 172.20.20.2
%No matching route to delete

Output of “show flow exporter”

!Gives only the status of the specified exporter
Router1#show flow exporter EXPORTER-10
Flow Exporter EXPORTER-10:
 Description: *** Exporter test ***
 Export protocol: NetFlow Version 9
 Transport Configuration:
 Destination IP address: 53.0.0.1
 VRF label: BLUE
 Source IP address: 10.0.0.1
 Source Interface: Loopback1
 Transport Protocol: UDP
 Destination Port: 9995
 Source Port: 51537
 DSCP: 0x0
 TTL: 255
 Output Features: Used

DHCP snooping

DHCP snooping drops the packets where the source MAC and the client MAC do not match


Path MTU Discovery (PMTUD)

Path MTU Discovery (PMTUD) is a standardized technique in computer networking for determining the maximum transmission unit (MTU) size on the network path between two IP hosts, usually with the goal of avoiding IP fragmentation.


Easy Virtual Networking (EVN)

EVN reduces network virtualization configuration significantly across the entire network infrastructure with the Virtual Network Trunk.


Excessive debugs

The router prioritize the console port over router functions. Hence the router is processing large amount of debug output to the console port, it may hang. VTY lines are recommended for debugging.


PPPoE phases

It has 2 phases:
– Active Discovery Phnase
– PPP session phase


NAT64 over NAT-PT

When implementing NAT64 over NAT_PT DNS and NAT will be completely independent.


One-way SNMP notification

Trap is one-way, as it only sends the notification to the manager.

Inform is two-way, as it sends the notification and waits for acknowledgement.


GRE tunnel 

Internet Protocol 47 = GRE tunnel


BGP states

  • Idle: refuses connection (initial state)
  • Connect: waits for the TCP connection to be completed
  • Active: listens for and accepts connection
  • OpenSent: waits for an OPEN message
  • OpenConfirm: waits for a Keepalive or Notification message
  • Established: Update, Notification and keepalive messages are exchanged with peers

Please notice the order!


OSPF states

  • down: No information has been received, but Hello packets can still be sent to the neighbor.
  • init: A Hello packet is received, but the ID of the receiving router was not included in the Hello packet.
  • 2-way: Each router see its own Router  ID in the neighbor field of the Hello packet; there is a DR/BDR election.
  • exstart: The routers and their DR and BDR establish a master-slave relation.
  • exchange: Routers exchange DBD packets that describe the contents of the entire link-state database.
  • loading: Based on the information provided by the DBD, routers send link-state request packets.
  • full: All the router and network LSAs are exchanged and the router databases are synchronized.

DHCP Option

DHCP provides a framework for passing configuration information to hosts on a TCP/IP network. Configuration parameters and other control information are carried in tagged data items that are stored in the options field of the DHCP message. The data items themselves are also called options.

Option 66: Identifies a TFTP server when the sname field in the DHCP header has been used for DHCP options.


Stateful and Stateless NAT64

 

Advertisements